AlexServeur Index du Forum S’enregistrer Connexion

Bug production de vaisseaux en série
Poster un nouveau sujet   Répondre au sujet
AlexServeur Index du Forum  » Support  » Univers Super Fun - Bugs et problèmes  » Bug production de vaisseaux en série
Sujet précédent :: Sujet suivant  
Auteur Message
Skynet
Modérateur

Hors ligne

Inscrit le: 23 Aoû 2008
Messages: 23

 Message Posté le: Mar 26 Aoû - 17:36 (2008)    Sujet du message: Bug production de vaisseaux en série
Répondre en citant

Pardonnez moi mais c'est la journée des soucis on dirait.

Lorsque je lance plusieurs types de vaisseaux en production, comme par exemple des rip et des Conquerors, sa lag et j'obtiens ce message d'erreur:

Fatal error: Maximum execution time of 10 seconds exceeded in /usr/export/www/hosting/alexserveur/Univers2/includes/functions/HandleElementBuildingQueue.php on line 38

Bien entendu je dispose des ressources suffisantes.

Je pense que c'est un bug propre à mon compte.
Si il était possible de le résoudre sa serait fort agréable car c'est légèrement chiant. Nan très chiant en faite Mr. Green

Merci d'avance.

Amicalement

Skynet


 Revenir en haut »
Publicité






 Message Posté le: Mar 26 Aoû - 17:36 (2008)    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
 Revenir en haut »
The Punisher


Hors ligne

Inscrit le: 24 Aoû 2008
Messages: 42

 Message Posté le: Mar 26 Aoû - 17:49 (2008)    Sujet du message: Bug production de vaisseaux en série
Répondre en citant

Je vais essayer de le reproduire, de lancer plusieurs vaisseaux, t'en lance combien ( le nombre ) et ( les types ) ?
Moi quand je lance, 9999999, sa peut lagger un peut mais vraiment peut, 4 a 5 secondes.
Et ça marche.
Tu en lance surement trop !

Fais  2 voir 3 type de vaisseaux en même temps, Maximum.


 Revenir en haut »
Skynet
Modérateur

Hors ligne

Inscrit le: 23 Aoû 2008
Messages: 23

 Message Posté le: Mar 26 Aoû - 18:02 (2008)    Sujet du message: Bug production de vaisseaux en série
Répondre en citant

Dernier essais effectué à l'instant:
Tentative de produire 5555555 Conquéror et Rip sans succès.

Même essais mais avec 2222222 et là sa marche.
Par contre si je rajoute un 3ème type de vaisseaux sa replante.
Le soucis est que le serveur annonce une queue de 9999999. Il devrait pouvoir supporter cette queue en lançant tous les types de vaisseaux en même temps comme c'est le cas ailleurs.
Perso, si je dois baisser la queue pour produire je baisse, mais ce qui m'ennuies c'est que c'est un problème de taille qui vas souler tous nouveau joueur arrivant, et nous avons besoin de nouveau joueurs.
La concurrence est rude, suffit de voir le top et le nombre de serveurs disponibles. ALEXSERVEUR doit être au même niveau que les meilleurs si nous voulons lui faire une place de choix.
Je pense très sincèrement que c'est un problème sur lequel il faut se pencher pour améliorer les queues.
Je ne suis pas codeur mais je sait que dire est facile, faire l'est moins. Je constate, je suggère, tout cela dans l'intérêt du serveur, rien de plus.
Si une solution peut être apportée, et il y en a forcément une puique sa fonctionne ailleurs, il serait bon de travailler deçu, voilà.

Skynet


 Revenir en haut »
The Punisher


Hors ligne

Inscrit le: 24 Aoû 2008
Messages: 42

 Message Posté le: Mar 26 Aoû - 18:24 (2008)    Sujet du message: Bug production de vaisseaux en série
Répondre en citant

J'ai une solution pour remédier à cela.

fait clic droit sur  " chantier Spatial " ensuite tu choisis ouvrir dans un nouvel onglet.
Si tu veut tu peut encore en ouvrir une autre, tu fais la même manip.

Ensuite tu va sur les onglets que t'a ouvert, et tu choisis le nombre que tu veut, 9999999.
 
CHAQUE ONGLET CHOISIS EST POUR UN TYPE DE VAISSEAU.
Exemple sur l'onglet 1, choisi 9999999 Chasseur léger.
onglet 2, choisi 9999999 Chasseur Lourd etc ..
Hop tu met construire.

J'ai fais ça et ça marche,
mais il faut faire ça ...


 Revenir en haut »
Skynet
Modérateur

Hors ligne

Inscrit le: 23 Aoû 2008
Messages: 23

 Message Posté le: Mar 26 Aoû - 19:13 (2008)    Sujet du message: Bug production de vaisseaux en série
Répondre en citant

Oui en effet sa fonctionne.
Cependant, tu reconnaitra que cette solution (d'attente) ne peux rester définitive et être présentée aux joueurs.
Mais sa fonctionne en effet.


 Revenir en haut »
The Punisher


Hors ligne

Inscrit le: 24 Aoû 2008
Messages: 42

 Message Posté le: Mar 26 Aoû - 19:28 (2008)    Sujet du message: Bug production de vaisseaux en série
Répondre en citant

Bien sûr je sais, que ceci ne peut pas rester définitif.
Mais je ne comprend pas ce " Bug " .. :s

Il n'y été pas avant, j'ai rien touché qui viens d'un fichier qui touche cela.
Bref, peut être que avec le temps ça va passé Mr. Green ou alors faire des essais !


 Revenir en haut »
Skynet
Modérateur

Hors ligne

Inscrit le: 23 Aoû 2008
Messages: 23

 Message Posté le: Mar 26 Aoû - 20:54 (2008)    Sujet du message: Bug production de vaisseaux en série
Répondre en citant

Je ne pense pas que tu y soit pour quoi que ce soit.
Et je pense qu'il est la depuis le début puisque j'ai eu l'occasion de parler de Alex Serveur avec des potes qui m'ont confirmé avoir eu le même problème, et c'est d'ailleurs la raison de leur départ pour un autre serveur. C'est bien sa qui me navre.
Je n'y avait prête attention jusqu'à aujourd'hui car je suis principalement mineur et je faisais juste des GT pour transporter mes ressources d'une colo à une autre. C'est aujourd'hui, en voulant me mettre sérieusement à la constitution d'une flotte que je me suis rendu compte que ce qu'on m'avais dit se confirmait. Sa freine grave les joueurs sa :s


 Revenir en haut »
The Punisher


Hors ligne

Inscrit le: 24 Aoû 2008
Messages: 42

 Message Posté le: Mar 26 Aoû - 21:32 (2008)    Sujet du message: Bug production de vaisseaux en série
Répondre en citant

Mais en faisant ma méthode, le problème n'existe plus.
Donc faudrait l'affiché en nouveauté ou autres !


 Revenir en haut »
Contenu Sponsorisé






 Message Posté le: Aujourd’hui à 12:01 (2018)    Sujet du message: Bug production de vaisseaux en série

 Revenir en haut »
Montrer les messages depuis:   
AlexServeur Index du Forum  » Support  » Univers Super Fun - Bugs et problèmes  » Bug production de vaisseaux en série
Poster un nouveau sujet   Répondre au sujet Toutes les heures sont au format GMT + 2 Heures
Page 1 sur 1

 
Sauter vers:  

Index | Panneau d’administration | créer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation


EnterGalaxy Template by [IDK]TargetX

Powered by phpBB © 2001, 2018 phpBB Group
Traduction par : phpBB-fr.com